segunda-feira, 22 de fevereiro de 2016

Programação de Computadores - 22/02/2016

Programação de Computadores - 22/02/2016

Resolução do exercício da aula anterior:

Algoritmo "Exercício 2"

Var num, I, quant2427: inteiro
       peso, altura, imc: real
       nummaior, nummenor: inteiro
       imcmaior, imcmenor: real

Início
   //inicializando as variáveis
   quant2427 <- 0;
   imcmaior <- 0;
   imcmenor <- 0;

 Para I de 1 até 20 faça
   //Entradas
   Escreva ("Informe o número de inscrição")
   Leia (num)
   Escreva ("Informe o peso e a altura")
   Leia (peso, altura)
   //calculando o IMC
   IMC <- (peso/altura²)
   //saída do IMC
   Escreva ("O seu IMC é:", IMC)
   //Quantidade de IMC entre 24 e 27
   Se (IMC >= 24 e IMC <= 27) então
      quant2427 <- (quant2427 + 1)
   fim se

   //descobrindo o número
   //com o maior IMC
   Se (IMC > IMCmaior) então
      nummaior <- num
      IMCmaior <- IMC
   fimse
   //descobrindo o número de inscrição
   //com o menor IMC
   Se (IMC < IMCmenor) ou (IMCmenor = 0) então
      nummenor <- num
      IMCmenor <- IMC
   fim se
 fim para
 //saída quantidade IMC entre 24 e 27
 Escreva ("Quantidade IMC entre 24 e 27 é:", quant2427)
 //Saída do número de inscrição do maior IMC:
 Escreva ("O número de inscrição com o maior IMC é:" nummaior)
 //Saída do número de inscrição com o menor IMC
 Escreva ("O número de inscrição com o menor IMC é:", nummenor)
fim algoritmo


// -- //


Transição C++
leia = CIN >>
escreva = COUT <<
Se = if
Senão = Else
Enquanto = While
Para = For

Operadores
+ Adição
- Subtração
/ Divisão
% Mod (resto de uma divisão inteira)
== Igualdade
!= diferente

Operadores Lógicos
e = &&
ou = ||

Tipos de dados
Inteiro INT
Real Float
Caracter String

Atribuição
soma <- 0 soma = 0;


# include <iostream>  /* bibliotecas são recursos para permitir que as funções funcionem /*
using namespace std;
int main(){
   int num1, num2;
   cout<< "Informe um número"<<endl; /* endl - endline - finaliza e pula uma linha
   cin>>num1;
   cout<<"Informe outro número"<<end;
   cin>>num2;
   If (num1 >= num2){
      cout<<"O número 1 é o maior"<<endl;
   }
   Else {
      cout<<"O número 2 é o menor"<< endl;
   }
   System ("Pause")
   Return 0;

-- // --

Programa para escrever em C++: code blocks

Lucas T R Freitas

Nenhum comentário:

Postar um comentário

Que a estrada se abra à sua frente,
Que o vento sopre levemente em suas costas,
Que o sol brilhe morno e suave em sua face,
Que a chuva caia de mansinho em seus campos,
E, até que nos encontremos, de novo, que Deus lhe guarde nas palmas de suas mãos!


Obrigado pelo seu comentário.

20/12/2017

Lucas Tiago Rodrigues de Freitas -- // -- Definite Chief Aim: "Viver tecnologicamente, cientificamente, trabalhando em parceria c...