quarta-feira, 17 de fevereiro de 2016

Programação de Computadores - 17/02/2016

Programação de Computadores - 17/02/2016

Programa para linguagem Portugol: visual g

Correção do exercício da última aula (exercício de somatório, quantidade e média)

Algoritmo "Revisão"

Var I, categoria, contexp, contimp: inteiro
       pvenda, pcusto, somaimp, mediaimp: Real

Início
   // Zerar as variáveis que vão receber 
   Contimp <- 0;
   pvenda <- 0;
   somaimp <- 0;
   mediaimp <- 0;
   contexp <- 0;

   Para I de 1 até 30 (passo 1) faça // "passo 1" é opcional, pois a estrutura "para" é auto-incrementável
      // Entradas
      Escreva ("Informe o preço de custo do ",I," º produto")
      Leia (pcusto)
      Escreva ("Informe a categoria, digite 1 para importação e 2 para exportação")
      Leia (cat)
      // Calculando o preço de venda
      Se (cat=1) então // operador relacional
         pvenda <- (pcusto * 1.15)
         contimp <- (contimp +1)
         somaimp <- (somaimp + pvenda)
      Senão
         Se (cat=2) então
            pvenda <- (pcusto *1.20)
            // Calculando a quantidade dos produtos exportação
            contexp <- (contexp +1)
         Senão
            Escreva ("Informe a categoria, digite 1 para importação e 2 para exportação")
            Leia (cat)
         fim se
      fim se
      Escreva ("O preço de venda do produto ", I," é ", pvenda)
   Fimpara
   Escreva ("A quantidade de produtos do tipo exportação é", contexp)
   Médiaimp <- (somaimp / contimp)
   Escreva ("A média é", Mediaimp)


-- // --

Exercício

Faça um algoritmo que leia o número de inscrição, o peso e a altura de 20 atletas corredores maratonistas. O algoritmo deverá retornar:
  • o IMC de cada maratonista
  • a quantidade de maratonistas com IMC entre (inclusive) 24 e 27
  • o número de inscrição do maratonista com maior IMC
  • o número de inscrição do maratonista com menor IMC
Observação: considere que não há IMC igual.


Lucas T R Freitas

Nenhum comentário:

Postar um comentário

Que a estrada se abra à sua frente,
Que o vento sopre levemente em suas costas,
Que o sol brilhe morno e suave em sua face,
Que a chuva caia de mansinho em seus campos,
E, até que nos encontremos, de novo, que Deus lhe guarde nas palmas de suas mãos!


Obrigado pelo seu comentário.

P!nk - U + Ur Hand

Lucas Tiago Rodrigues de Freitas -- // -- Definite Chief Aim: "Viver tecnologicamente, cientificamente, trabalhando em parceria co...