terça-feira, 16 de fevereiro de 2016

Programação de Computadores - 15/02/2016

Programação de Computadores - 15/02/2016

ID 102

Material no ESO
Não tem atividade para fazer no ESO

25/06 - Exame contextualizado - 20% da nota

Prova 1 - 30/03 - Introdução a C++
Prova 2 - 25/05 - Manipulação de arquivos / Funções / Vetores
Prova 3 - 24/06 - Vetores e Matrizes

Ambiente: Dev C++

- Modularizar / Particionar o código
- Matrizes e Vetores

- // -

Estrutura de Repetição: Para Faça

Sintaxe
Para I de 1 até 100 passo 1 faça
   Escreva I
Fim para


  • I de 1 - inicialização
  • até 10 - condição de término
  • passo 1 - incremento (a ser realizado no fim da função)
-- / --

Revisão: Estrutura Enquanto faça

Algoritmo "nome"

Var I: inteiro

Início
   I <- 1 -- (Inicialização - I recebe 1)
   Enquanto (I <= 4) faça -- (condição de término)
      Escreva (I)
      I <- (I + 1) -- incremento - faz a estrutura de repetição avançar
   Fim Enquanto
Fim algoritmo


Variável fica em um espaço de memória alocado (reservado) no computador
  • Pode ser do tipo:
    • inteiro
    • real
    • caracter
    • boleano
Para (For) é uma estrutura auto-incrementável: é de 1 em 1

Para I de 2 até 100 passo 2 faça
   Escreva I
Fim para

-- / --

Soma <- 0
Para I de 2 até 10 passo 2 faça
   soma <- (soma + I)
Fim para
   escreva soma


-- / --

Para I de 100 até 1 passo -1 faça
   Escreva (I)
fim para


-- / --
Exercício de revisão - Repetição "para... faça"
1) Faça um algoritmo que calcule o preço de venda de 30 produtos. O algoritmo fará a leitura do preço de custo de cada produto e a categoria do produto, considere categoria "importação" e "exportação". O preço de venda de um produto é calculado em função da categoria, produtos do tipo "importação" possuem taxa de 15% de lucro sobre o preço de custo e produtos do tipo "exportação" possuem uma taxa de 20% de lucro sobre o preço de custo.

O algoritmo deverá retornar:
a) O preço de venda de cada produto
b) A quantidade de produtos do tipo exportação
c) A média dos preços de venda dos produtos do tipo "importação"


Minha resolução (não corrigida)

Categoria: caracter
Preço de custo = real
Preço de venda = real
soma preços de venda = real
número de itens import = inteiro
média import = real
itens export = inteiro

soma preços de venda <- 0
número de itens import <- 0
itens export <- 0

Para I de 1 a 30 faça
   se categoria == importação
      Preço de venda I = preço de custo I * 1,15
      número de itens import <- (número de itens import + 1)
      soma preços de venda <- (soma preços de venda + Preço de venda I)
   senão
      Preço de venda I = preço de custo I * 1,20
      itens export <- (itens export + 1)
Fim para
Para I de 1 a 30 faça
   escreva preço
Fim para
   escreva itens export
   média import <- (soma preços de venda / número de itens import)
   escreva média import



Lucas T R Freitas

Nenhum comentário:

Postar um comentário

Que a estrada se abra à sua frente,
Que o vento sopre levemente em suas costas,
Que o sol brilhe morno e suave em sua face,
Que a chuva caia de mansinho em seus campos,
E, até que nos encontremos, de novo, que Deus lhe guarde nas palmas de suas mãos!


Obrigado pelo seu comentário.

P!nk - U + Ur Hand

Lucas Tiago Rodrigues de Freitas -- // -- Definite Chief Aim: "Viver tecnologicamente, cientificamente, trabalhando em parceria co...